XCS Can't Find the Device Through Wi-Fi (P2)

Article author
xTool Customer Service
  • Updated

Issue Description

After connecting the P2 machine to the computer via Wi-Fi, the machine's name can't be found in the device list under the Wi-Fi option in XCS, as shown below.

#1 Affected by VPN Software

Please close any VPN on your computer and restart the software to connect again.
 

#2 Unstable Wi-Fi Connection

Change to another Wi-Fi network in case the signals aren't strong enough.
 

#3 Special Characters in Wi-Fi Name and Password

  1. Make sure your Wi-Fi name and password consist of only alphanumeric characters.
  2. Make sure you enter the correct password.

#4 Unsupported Wi-Fi Frequency Band

Make sure your Wi-Fi is in the 2.4 GHz band, not the 5 GHz band. And try again.

 

#5 Wi-Fi Is Not Configured

For the first time you connect P2 to your Wi-Fi, you need to connect it to your computer by USB first and configure the Wi-Fi connection using the XCS software.
 

#6 Device Is Hidden From the Device List

  1. Connect the device to your computer with the USB cable.
  2. Open your browser and input this in the address bar and hit enter:
  3. This will give you the name of the Wi-Fi connected last time.
  4. If the webpage shows {"result": "failed"} or other Wi-Fi names, configure the Wi-Fi on XCS again.
  1. Input this in the address bar and hit enter: http://201.234.3.1:8080/net?action=ifconfig
  2. This will give you the IP address needed for the connection. Copy the text between the quotation marks after “wlan0-ip”, as shown below.
  1. Launch XCS and go to the IP tab under the Connect device window.
  2. Paste the IP address and click "connect".

Was this article helpful?

0 out of 2 found this helpful

Have more questions?

Comments

0 comments

Article is closed for comments.